Adobe Commerce / Magento Open Sourceを利用する事業者が2024年のうちに対処したほうがよいこと

2024年が始まって早くも10日ほどが過ぎました。
今年はAdobe Commerce / Magento Open Source 2.4.7が4月にリリースされる予定になっています。昨年の2.4.6のリリースからは約1年なので、順当なリリースとなっています。
今回は2024年のAdobe Commerce / Magento Open Sourceのリリース予定を踏まえ、年内にどのような対処をすることが望ましいかについて解説していきたいと思います。

現在サポートされているバージョンの整理

2024年1月現在、公式にサポートされているAdobe Commerce / Magento Open Sourceのバージョンは以下のとおりです。

  • 2.4.4
  • 2.4.5
  • 2.4.6

4月以降はここに2.4.7が加わりますが、1月現在においては上記のバージョンが公式サポート対象です。
(Adobe Commerce向けには有償の延長サポートがありますが、一旦除外しています)

対応PHPバージョンの整理

次に各バージョンが対応するPHPバージョンの整理をしておきましょう。
Adobe Commerce / Magento Open Sourceのバージョンごとの対応PHPバージョンは下表のとおりです。

バージョン番号 正式リリース日 サポート終了日 対応PHPバージョン
2.4.7 2024/04/09 2027/04/09 8.2 / 8.3
2.4.6 2023/03/14 2026/03/14 8.1 / 8.2
2.4.5 2022/08/09 2025/08/09 8.1
2.4.4 2022/04/12 2025/04/24 8.1

PHP8.3対応は2.4.7からとなっています。
4月以降に新規で構築する場合は別として、既存サイトについては慌てずに2.4.6系の最新にアップデートするほうが無難でしょう。

PHP本体のメンテナンス期限

PHP公式によると、各PHPバージョンのメンテナンス期限は下表のとおりです。

バージョン番号 初回リリース アクティブサポート期限 セキュリティサポート期限
8.1 2021/11/25 2023/11/25 2024/11/25
8.2 2022/12/08 2024/12/08 2025/12/08
8.3 2023/11/23 2025/11/23 2026/11/23

2024年にメンテナンス期限を迎えるのは8.1系となっています。
「11月25日で期限切れ」となっているので、この日よりも前にPHP8.2以上のバージョンへ切り替える必要があります。

2024年中に各事業者は何をするべきか

ここまでの内容を整理しましょう。
Adobe Commerce / Magento Open Sourceのバージョン別に取るべき対策は異なります。

2.4.4 / 2.4.5系

まず最優先で対処しなければいけないこととしては、2.4.6系以降へのアップデートです。

PHP8.1が11月25日にメンテナンス終了となることを踏まえると、以下のようなスケジュール感で作業を進めることが望ましいと思われます。

  1. 1月〜6月:2.4.6系へのアップデート
  2. 7月〜10月:PHP8.2への切り替え
  3. 10月〜11月:経過観察。2.4.7への移行準備

2.4.4/2.4.5と2.4.6はPHP8.1が共通して利用できます。
二度手間にはなってしまいますが、一度にアプリケーションとPHPの切り替えを行うよりはリスクを回避しつつアップデートの実施が可能です。

2.4.6系

2.4.6系の場合はかなり余裕があります。
PHP8.1系で稼働している場合はPHP8.2系への切り替えが必要です。まずこの作業が最優先となります。
既にPHP8.2で稼働している場合は、セキュリティリリースの適用やPHPのマイナーアップデート対応だけで済むため、かなり楽です。

2.4.3系 / 2.3系

もう既に公式にはサポートが終了しています。
原則的には延長サポートに期待するのではなく、2.4.6以降へのアップデートを速やかに進める必要があります。
特に対応するPHPバージョンが大きく異なる場合は、アップデートの難易度も高くなる傾向があります。十分なテストの実施と移行計画の策定が不可欠です。

アップデートのご相談について

弊社では、稼働中のAdobe Commerce / Magento Open Sourceに対する有償アップデート作業を承っております。
アップデートをご検討中の事業者様は、「お問合せフォーム」よりご連絡ください。