そして、弊社では「Magento日本語ロケール 」をMgento Community Edition 1.9.1.0に対応させました。
Magento Connectでも配布をしておりますし、最新版は常時Githubにて公開していますので、ぜひご利用ください。

なお、今回のバージョンアップに伴い、1.9.1.0用と1.9.0.1以前用にロケールが分かれました。
これはレスポンシブメールテンプレートが1.9.1.0で導入されたことが原因です。
ロケール単体としては1.9.1.0用を1.9.0.1以前でご利用いただいても全く問題はありませんが、メールテンプレートについては互換性がありませんので注意が必要です。

未訳や誤訳等に関するご指摘やもっと良い翻訳のご提案は、GithubのIssueまでよろしくお願いいたします。